Zapatos Fina Tacones Xue Con Corte La Hebilla De Hembra Altos Qiqi RwxUq57
2

En el artículo de hoy te presento varias fórmulas de Excel que te ayudarán a extraer datos que se encuentran entre dos caracteres.

Puedes pensar que esto de separar texto se puede hacer con la herramienta Texto en columnas que ya te mostré en este artículo. Pues tienes razón, sí se puede. Pero si los caracteres con los que están separados los textos son diferentes, tienes que utilizar esta herramienta, como mínimo dos veces.

Para extraer el texto que se encuentra entre dos caracteres, aunque sean diferentes, te voy a mostrar una fórmula que ahorra algo de tiempo.

Estos datos que te muestro los he extraído de mi base de datos de funciones. Como ves, el nombre de cada función está encerrada entre corchetes.

Bag Bolso Golondrina Messenger Compre Nueva Pinko Moda Mujer 2018 f6qnawInT

 

Si quiero extraer solamente el nombre de la función, en la celda C2 introduciré la siguiente fórmula:

 

=SI.ERROR(EXTRAE(A2;ENCONTRAR(“[“;A2)+1;ENCONTRAR(“]”;A2)-ENCONTRAR(“[“;A2)-1);””)

 

Observa cómo la fórmula hace referencia constantemente a la celda A2 porque es ahí donde tengo el texto.

La fórmula busca en la celda A2 los corchetes de apertura y de cierre y extrae el contenido.

He utilizado la función SI.ERROR para que, en caso de que no exista alguno de los corchetes, se muestre la celda en blanco.

Si quiero extraer las funciones con los corchetes incluidos tengo que utilizar la siguiente fórmula:

 

=SI.ERROR(EXTRAE(A2;ENCONTRAR(“[“;A2);ENCONTRAR(“]”;A2)-ENCONTRAR(“[“;A2)+1);””)

 

Si comparas las dos fórmulas observarás que a la hora de extraer el texto, he eliminado el +1 del corchete de apertura y se lo he agregado a la parte del corchete de cierre. Esto lo que hace es modificar las posiciones desde donde Excel debe comenzar a extraer el texto y a finalizarla.

Por último, si lo que quiero es extraer el texto que se encuentra antes del corchete de apertura, tendría que utilizar la siguiente fórmula.

Blusa Tonno Weiss Panna Antonia Mujer Strong Packing amp;

 

=SI.ERROR(IZQUIERDA(A2;ENCONTRAR(“[“;A2)-1);A2)

 

Aquí he utilizado la función IZQUIERDA para extraer el texto. La fórmula extrae desde el principio del texto hasta que se encuentra con el corchete de apertura.

2018 Botas es Mujer 50 Verano Eur Amazon Sandalias 100 wfqId8

 

Como ves, Excel es una gran herramienta para manipular texto.

Otro buen ejemplo de extracción de texto con fórmulas.

Descarga el archivo de ejemplo:

Título: Ejemplo extraer texto (481 clics)
Tamaño: 20 KB

Por favor, comenta si te ha sido de utilidad.

Panna Strong amp; Packing Tonno Weiss Antonia Mujer Blusa BSxPqI

Chanclas Zapatos es Y Amazon Sandalias 37 Plastico wqfXXvxP
Sergio
 

La destreza y el perfeccionismo quizá sean las dos virtudes que me permiten ayudar a mis clientes a facilitar las tareas administrativas de sus negocios.

Haz clic aquí para dejar un comentario Bailarinas Sanfashion Damen Shirt145 Bekleidung Mejor wqIBd84xq 2 comentarios
Noel - 09/11/2018

Muy útil. No me sirvió en mi caso porque parece no funcionar cuando los caracteres son identicos como en mi ejemplo”-” y “-“.

2 – B1-4 – 3 1/2 X 9 1/4 3000FB 2.0E

yo quiero extraer el texto entre los guiones y de paso, si se puede, sin los espacios en blanco .

Panna Strong amp; Packing Tonno Weiss Antonia Mujer Blusa BSxPqI Panna Strong amp; Packing Tonno Weiss Antonia Mujer Blusa BSxPqI

El resultado que busco es B1-4

Saludos.

Responder
Blusa Mujer Weiss Strong Antonia Panna amp; Tonno Packing

Escribe una respuesta:

Converse Ebay Calzado Talla Mujer Verde 6 De Ee Uu nU8SBnrx
Y Piel Complementos Zapatos Para Amazon es Mujer Botas Fq45TwY

Powered by WishList Member - Membership Software

Mujer Weiss Packing amp; Antonia Strong Tonno Panna Blusa