Punta Para Mujer De Zapatos Rafania Cerrada Tacón Negro Lodi Con XFZqW4
2

En el artículo de hoy te presento varias fórmulas de Excel que te ayudarán a extraer datos que se encuentran entre dos caracteres.

Puedes pensar que esto de separar texto se puede hacer con la herramienta Texto en columnas que ya te mostré en este artículo. Pues tienes razón, sí se puede. Pero si los caracteres con los que están separados los textos son diferentes, tienes que utilizar esta herramienta, como mínimo dos veces.

Para extraer el texto que se encuentra entre dos caracteres, aunque sean diferentes, te voy a mostrar una fórmula que ahorra algo de tiempo.

Estos datos que te muestro los he extraído de mi base de datos de funciones. Como ves, el nombre de cada función está encerrada entre corchetes.

Hombre Libre Y es Aire Complementos Amazon Para Zapatos 1RxwnqOWzZ

 

Si quiero extraer solamente el nombre de la función, en la celda C2 introduciré la siguiente fórmula:

 

=SI.ERROR(EXTRAE(A2;ENCONTRAR(“[“;A2)+1;ENCONTRAR(“]”;A2)-ENCONTRAR(“[“;A2)-1);””)

 

Observa cómo la fórmula hace referencia constantemente a la celda A2 porque es ahí donde tengo el texto.

La fórmula busca en la celda A2 los corchetes de apertura y de cierre y extrae el contenido.

He utilizado la función SI.ERROR para que, en caso de que no exista alguno de los corchetes, se muestre la celda en blanco.

Si quiero extraer las funciones con los corchetes incluidos tengo que utilizar la siguiente fórmula:

 

=SI.ERROR(EXTRAE(A2;ENCONTRAR(“[“;A2);ENCONTRAR(“]”;A2)-ENCONTRAR(“[“;A2)+1);””)

 

Si comparas las dos fórmulas observarás que a la hora de extraer el texto, he eliminado el +1 del corchete de apertura y se lo he agregado a la parte del corchete de cierre. Esto lo que hace es modificar las posiciones desde donde Excel debe comenzar a extraer el texto y a finalizarla.

Por último, si lo que quiero es extraer el texto que se encuentra antes del corchete de apertura, tendría que utilizar la siguiente fórmula.

Para Tops Lactancia Multifuncional Fulision De Mujeres

 

=SI.ERROR(IZQUIERDA(A2;ENCONTRAR(“[“;A2)-1);A2)

 

Aquí he utilizado la función IZQUIERDA para extraer el texto. La fórmula extrae desde el principio del texto hasta que se encuentra con el corchete de apertura.

es Mujer Zapatos De Botines Tacón 2040889031 Amazon 1SzFCTz

 

Como ves, Excel es una gran herramienta para manipular texto.

Otro buen ejemplo de extracción de texto con fórmulas.

Descarga el archivo de ejemplo:

Título: Ejemplo extraer texto (481 clics)
Tamaño: 20 KB

Por favor, comenta si te ha sido de utilidad.

Fulision Mujeres De Tops Para Multifuncional Lactancia TqqBU6wF

Chanclas Zapatos es Y Amazon Sandalias 37 Plastico wqfXXvxP
Sergio
 

La destreza y el perfeccionismo quizá sean las dos virtudes que me permiten ayudar a mis clientes a facilitar las tareas administrativas de sus negocios.

Haz clic aquí para dejar un comentario Señoras Sohoeos Para Mujer Vintage Verano Flat Sandalias BIITzwqa 2 comentarios
Noel - 09/11/2018

Muy útil. No me sirvió en mi caso porque parece no funcionar cuando los caracteres son identicos como en mi ejemplo”-” y “-“.

2 – B1-4 – 3 1/2 X 9 1/4 3000FB 2.0E

yo quiero extraer el texto entre los guiones y de paso, si se puede, sin los espacios en blanco .

Fulision Mujeres De Tops Para Multifuncional Lactancia TqqBU6wF Fulision Mujeres De Tops Para Multifuncional Lactancia TqqBU6wF

El resultado que busco es B1-4

Saludos.

Responder
Fulision Tops Para Mujeres De Lactancia Multifuncional
    Sergio - 10/11/2018

    Hola, Noel!

    Ya sabes que con Excel tienes mil formas de llegar al mismo resultado…Tubo Kaysa Nieve Mujeres Las De Botas Corto Invierno Bt fW88Ont

    Echa un vistazo a esta fórmula:

    =EXTRAE(A2;HALLAR(“- “;A2;1)+2;HALLAR(” -“;A2;HALLAR(“-“;A2;1)+1)-HALLAR(“-“;A2;1)-1)

    Tú comentas que es el mismo caracter el que delimita el texto a extraer, pero no es del todo cierto. En realidad los delimitadores son “- ” (con un espacio al final) desde el que se comienza a extraer, y un ” -“(con un espacio al principio) hasta el que se extrae. Esto también te permite eliminar los espacios innecesarios.

    Espero que te sirva.

    Responder

Escribe una respuesta:

Para Fitflop Mujer Negro Pop Crystal X Zapatillas Sporty Sneaker 0YrZw0q
Manga De Corta Marengo Camiseta Trabajo Gris Camisa OE6x8O

Powered by WishList Member - Membership Software

Tops Lactancia Para De Mujeres Fulision Multifuncional